Visualg

Origem: Wikipédia, a enciclopédia livre.
Ir para: navegação, pesquisa

O Visualg (Visualizador de Algoritmo) é um programa que edita, interpreta e executa algoritmos com uma linguagem próxima do português estruturado como um programa normal de computador[1] .

Descrição[editar | editar código-fonte]

O Visualg é um bom recurso para quem está iniciando no aprendizado de algoritmos, não só para praticar a sua criação mas também para melhor entender sua execução por meio do visualizador de variáveis que funciona como um depurador[2] .

Na versão 2.5, o Visualg possuia recursos como simulação da "tela" do computador, visualização de variáveis, breakpoints, ajuda on-line, impressão dos fontes e outras características que auxiliam o aprendizado das técnicas de programação.

Atualmente o software encontra-se na versão 3.01, com um novo Layout(leiaute), além de novas roupagens, com aparência de metal, madeira, plástico, alumínio e outros. Agora se pode também digitar nomes de comandos em português correto, como FAÇA (faca), ATÉ (ate), NÃO (nao), SENÃO (senao), etc. Pode ser baixado pelo site do Source Forge: https://sourceforge.net/projects/visualg30/

Referências

  1. *Manual do ambiente de programação do Visualg
  2. *. Também permite a criação de funções e procedimentos.Página oficial do Visualg

Ligações externas[editar | editar código-fonte]

  • Apostila PDF de introdução a algoritmos utilizando o Visual-G
  • exemplo
  • algoritmo "IRRF" // Função : Calcular Imposto de Renda // // Seção de Declarações var salario, imposto, salliq : real inicio escreva ("informe o salário Bruto: ") leia (salario) se (salario <= 1903.98) entao escreval ("Isento do IRRF") senao se (salario >= 1903.99) e (salario <= 2826.65) entao imposto := (salario * 0.075) - 142.80 fimse se (salario >= 2826.66) e (salario <= 3751.05) entao imposto := (salario * 0.15) - 354.80 fimse se (salario >= 3751.06) e (salario <= 4664.68) entao imposto := (salario * 0.22) - 636.13 fimse se (salario >= 4664.69) entao imposto := (salario * 0.275) - 869.36 fimse fimse salliq := salario - imposto escreval ("O salario Bruto = ", salario) escreval ("O Você pagará de IRRF = ", imposto) escreva ("Seu salário líquido = ", salliq) fimalgoritmo