Pseudocódigo

Origem: Wikipédia, a enciclopédia livre.
Ir para: navegação, pesquisa
Question book.svg
Esta página ou secção não cita nenhuma fonte ou referência, o que compromete sua credibilidade (desde fevereiro de 2011).
Por favor, melhore este artigo providenciando fontes fiáveis e independentes, inserindo-as no corpo do texto por meio de notas de rodapé. Encontre fontes: Googlenotícias, livros, acadêmicoScirusBing. Veja como referenciar e citar as fontes.

Pseudocódigo é uma forma genérica de escrever um algoritmo, utilizando uma linguagem simples (nativa a quem o escreve, de forma a ser entendida por qualquer pessoa) sem necessidade de conhecer a sintaxe de nenhuma linguagem de programação. É, como o nome indica, um pseudocódigo e, portanto, não pode ser executado num sistema real (computador) — de outra forma deixaria de ser pseudo.

Os livros sobre a ciência de computação utilizam frequentemente o pseudocódigo para ilustrar os seus exemplos, de forma que todos os programadores possam entendê-los (independentemente da linguagem que utilizem).

No caso da língua portuguesa existam alguns interpretadores de pseudocódigo, nenhum tem a projecção das linguagens Pascal ou BASIC, que no caso da língua inglesa se assemelham bastante a um pseudo-código.

Um programa para compilar um código em portugol é o VisuALG ou Portugol Viana que podem ser baixados de qualquer site de busca como o Google.

Pseudolinguagem ou pseudocódigo (Portugol)[editar | editar código-fonte]

É uma linguagem de programação genérica e rica em detalhes. É um tipo de linguagem chamada de linguagem de projeto de programação. Essa pseudolinguagem assemelha-se bastante à forma como os programas são escritos. A diferença entre a descrição narrativa e o pseudocódigo está principalmente no vocabulário finito e bem menor do pseudocódigo e nas estruturas de controle que apresenta. A utilização de uma gama menor de termos facilita a expressão do raciocínio lógico na medida em que reduz a possibilidade de mal entendimento das instruções.

Exemplo[editar | editar código-fonte]

Abaixo vemos o exemplo de um programa que faz a leitura de dez números e calcula a média dos números positivos:

VARIAVEIS
S,C,I,A,MD:Real;
INÍCIO 
S ← 0;
C ← 0;
PARA I← 1 ATÉ 10 FAÇA
  INÍCIO
    Escreva ('Digite um número');
    LEIA (a);
    SE a >=0 ENTÃO
       INÍCIO
         S ← S+a;
         C ← C+1;
       FIM;
    FIM SE;
  FIM;
FIM PARA;
MD ← S/C;
ESCREVER ('A média é:', MD);
FIM.

Ver também[editar | editar código-fonte]

Referências

Ícone de esboço Este artigo sobre programação de computadores é um esboço. Você pode ajudar a Wikipédia expandindo-o.

[1]
Erro de citação: existem marcas <ref>, mas falta adicionar a predefinição {{referências}} no final da página